Вход на сайт

Просмотр новости

Найдите то, что Вас интересует

Issues with fiber channel multipathing on HPE ProLiant DL385?

Дата публикации: 27-09-2026 02:57:32

Hello all.I'm having a hell of a time trying to get fiber channel multipathing working across all three of our lovely HPE ProLiant DL385 Gen10 servers. We're using HPE QLE2692-HP/SN1100Q dual-port fiber channel HBAs in all three systems, connecting to Finisar FTLF8528P3BCV-QL transceivers across two linked QLogic SANBox 5802V fiber channel switches. Obviously, the objective is to have multipathing for redundancy here, but I cannot for the life of me figure out how to get this. I'll get ONE side working OR the other, but not both. I've checked my fabric pathing, the "polarity" of my cables (they are all the same fiber cable), etc, and I'm not sure what I might be missing here.As of 25 September 2026:server-01: This server WASN'T using one of those Finisar FTLF8528P3BCV-QL transceivers initially in switch-01. It was using some silly old thing only capable of 4 gbps. I swapped that out on 26 September 2026, with some interesting effects (see below).[23:16 server-01 ~]# cat /sys/class/fc_host/host0/port_state Online[23:16 server-01 ~]# cat /sys/class/fc_host/host3/port_state Online[23:16 server-01 ~]# multipath -ll36f01faf000cf7ade000001c263ee3f04 dm-0 DELL ,MD36xxf size=3.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw|-+- policy='round-robin 0' prio=12 status=enabled| |- 0:0:1:10 sde 8:64 failed ready running| `- 3:0:0:10 sdg 8:96 failed ready running`-+- policy='round-robin 0' prio=11 status=active|- 0:0:0:10 sdc 8:32 active ready running`- 3:0:1:10 sdi 8:128 active ready runningSep 25 23:08:23 | sdf: rdac prio: inquiry command indicates errorSep 25 23:09:23 | sdh: rdac prio: inquiry command indicates error36d4ae520008094180000251d641023af dm-2 DELL ,MD36xxf size=5.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw|-+- policy='round-robin 0' prio=0 status=enabled| |- 0:0:1:11 sdf 8:80 failed faulty running| `- 3:0:0:11 sdh 8:112 failed faulty running`-+- policy='round-robin 0' prio=11 status=active|- 0:0:0:11 sdd 8:48 active ready running`- 3:0:1:11 sdj 8:144 active ready runningserver-02: This server WAS working on switch-01, and when I swapped out the transceiver on switch-02... started working only on switch-02. ಠ_ಠ[23:05 server-02 ~]# cat /sys/class/fc_host/host0/port_stateLinkdown[23:15 server-02 ~]# cat /sys/class/fc_host/host3/port_stateOnline[23:15 server-02 ~]# multipath -ll36f01faf000cf7ade000001c263ee3f04 dm-1 DELL ,MD36xxf size=3.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw|-+- policy='round-robin 0' prio=12 status=enabled| `- 3:0:0:10 sdc 8:32 failed ready running`-+- policy='round-robin 0' prio=11 status=active`- 3:0:1:10 sdd 8:48 active ready running36d4ae520008094180000251d641023af dm-2 DELL ,MD36xxf size=5.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw`-+- policy='round-robin 0' prio=11 status=active`- 3:0:1:11 sde 8:64 active ready runningserver-03:[22:56 server-03 ~]# cat /sys/class/fc_host/host0/port_state Online[22:56 server-03 ~]# cat /sys/class/fc_host/host3/port_state Linkdown[22:56 server-03 ~]# multipath -ll36f01faf000cf7ade000001c263ee3f04 dm-0 DELL ,MD36xxf size=3.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw|-+- policy='round-robin 0' prio=12 status=enabled| `- 0:0:1:10 sde 8:64 failed ready running`-+- policy='round-robin 0' prio=11 status=active`- 0:0:0:10 sdc 8:32 active ready running36d4ae520008094180000251d641023af dm-2 DELL ,MD36xxf size=5.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw`-+- policy='round-robin 0' prio=11 status=active`- 0:0:0:11 sdd 8:48 active ready runningAs of 26 September 2026:Replaced the transceiver in switch-01 for server-01 to one of those Finisar FTLF8528P3BCV-QL so that it would, like the other servers, be capable of a full 8 gbps. As soon as I did this and powered up the other servers, almost all paths were rectified - server-03 had TWO active ports.At this point, ONLY server-02 has a port that is not seen by the fiber channel switch, specifically, switch-01. The port it is plugged into is correctly zoned with ALL THE REST OF THE PORTS (in the switch fabric) that are working fine for server-01 and server-03, and I tried swapping the cable. I suppose I could try that again - but again, THIS CABLE was KNOWN TO BE working good.I have verified all of my systems against the storage array by doing cat /sys/class/fc_host/hostX/port_name and verifying that they are consistent with the "Host Port Identifiers" associated with each host in my Dell MD3600f storage array software (and, again, this works just fine with the other two servers).I HAVE noted that the firmware on my HPE SN1100Q dual-port fiber channel HBA cards is NOT fully up-to-date - it is version 9.14.00, which is dated 22 March 2024, per this page.server-01:[20:31 server-01 ~]# cat /sys/class/fc_host/host0/port_state Online[20:47 server-01 ~]# cat /sys/class/fc_host/host3/port_state Online[20:48 server-01 ~]# multipath -ll36f01faf000cf7ade000001c263ee3f04 dm-0 DELL ,MD36xxf size=3.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw|-+- policy='round-robin 0' prio=14 status=active| |- 0:0:1:10 sde 8:64 active ready running| `- 3:0:0:10 sdg 8:96 active ready running`-+- policy='round-robin 0' prio=9 status=enabled|- 0:0:0:10 sdc 8:32 active ready running`- 3:0:1:10 sdi 8:128 active ready running36d4ae520008094180000251d641023af dm-2 DELL ,MD36xxf size=5.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw|-+- policy='round-robin 0' prio=12 status=enabled| |- 0:0:1:11 sdf 8:80 failed ready running| `- 3:0:0:11 sdh 8:112 failed ready running`-+- policy='round-robin 0' prio=11 status=active|- 0:0:0:11 sdd 8:48 active ready running`- 3:0:1:11 sdj 8:144 active ready runningserver-02:[20:30 server-02 ~]# cat /sys/class/fc_host/host0/port_state Linkdown[20:49 server-02 ~]# cat /sys/class/fc_host/host3/port_state Online[20:49 server-02 ~]# multipath -ll36f01faf000cf7ade000001c263ee3f04 dm-1 DELL ,MD36xxf size=3.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw|-+- policy='round-robin 0' prio=14 status=active| `- 3:0:0:10 sdc 8:32 active ready running`-+- policy='round-robin 0' prio=9 status=enabled`- 3:0:1:10 sde 8:64 active ready running36d4ae520008094180000251d641023af dm-0 DELL ,MD36xxf size=5.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw|-+- policy='round-robin 0' prio=12 status=enabled| `- 3:0:0:11 sdd 8:48 failed ready running`-+- policy='round-robin 0' prio=11 status=active`- 3:0:1:11 sdf 8:80 active ready runningserver-03:[20:28 server-03 ~]# cat /sys/class/fc_host/host0/port_state Online[20:51 server-03 ~]# cat /sys/class/fc_host/host3/port_state Online[20:51 server-03 ~]# multipath -ll36f01faf000cf7ade000001c263ee3f04 dm-0 DELL ,MD36xxf size=3.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw|-+- policy='round-robin 0' prio=14 status=active| |- 0:0:1:10 sde 8:64 active ready running| `- 3:0:1:10 sdi 8:128 active ready running`-+- policy='round-robin 0' prio=9 status=enabled|- 0:0:0:10 sdc 8:32 active ready running`- 3:0:0:10 sdg 8:96 active ready running36d4ae520008094180000251d641023af dm-2 DELL ,MD36xxf size=5.5T features='3 queue_if_no_path pg_init_retries 50' hwhandler='1 rdac' wp=rw|-+- policy='round-robin 0' prio=12 status=enabled| |- 0:0:1:11 sdf 8:80 failed ready running| `- 3:0:1:11 sdj 8:144 failed ready running`-+- policy='round-robin 0' prio=11 status=active|- 0:0:0:11 sdd 8:48 active ready running`- 3:0:0:11 sdh 8:112 active ready running

Схожие новости

#Наименование новостиТональностьИнформативностьДата публикации
1Query: DL360p Gen8 System Power Fault07.525-09-2026
2HP DL380p Gen8 – Replacement drive immediately showing Failed013.9725-09-2026
3Query: HPE OneView DCS - Synergy Simulator05.5225-09-2026
4Re: HPE Nimble storage controller HA issue08.8126-09-2026
5Re: CRITICAL: Prolonged Cluster Partition / Split-Brain on 3-Node HPE VME 8 Cluster010.4127-09-2026
6Re: Query: HPE OneView DCS - Synergy Simulator06.1425-09-2026
7Re: NFS datastore permission error06.8825-09-2026
8Re: HPE Nimble array certificate renewal08.0825-09-2026
9Recovering a Morpheus Appliance from MySQL InnoDB Corruption07.6426-09-2026
10Re: Shut down a virtual machine from the WebUI08.3626-09-2026

Классификация: . Схожих патентов: 0. Схожих новостей: 10. Тональность: 0. Информативность: 8.78. Источник: community.hpe.com.